SL4 64bit WN

From EGEE-see WIki
Jump to: navigation, search

IL-BGU notes on configuring WN_torque on SLC 4.4 (64 bit) with production glite (32 bit)

I will write only the glite related installation info.

1) CERN Scientific Linux 4.4 was installed using minimal installation.

2) First update the basic system

yum update

3) enable jpackage16-generic repo in /etc/yum.repos.d/jpackage.repo

enable dag repo in /etc/yum.repos.d/dag.repo

also disable the yum protection of cern repositories and update again

sed -i -e 's/^protect=1/protect=0/' /etc/yum.repos.d/cern.repo
sed -i -e 's/^protect=1/protect=0/' /etc/yum.repos.d/cern-update.repo
sed -i -e 's/^protect=1/protect=0/' /etc/yum.repos.d/cern-extra.repo
yum update

4) Make shure yum autoupdate check only

sed -i -e 's/^YUMMAILTO="root"/YUMMAILTO="SITE_EMAIL"/'/etc/sysconfig/yum-autoupdate
sed -i -e 's/^YUMUPDATE=1/YUMUPDATE=0/' /etc/sysconfig/yum-autoupdate
service yum-autoupdate start

5) Install java

rpm -i j2sdk-latest.i586.rpm

6) Install yum priorities plugin (not available in SL & SLC repositories) more info at

You can get it from CentOS 4 Extras repo

rpm -i yum-plugin-priorities-0.0.3-1.c4.noarch.rpm

7) Configure glite repos

cat > /etc/yum.repos.d/glite.repo <<EOF
name=gLite 3.0

name=Torque clients

Notice that [glite] repo is given the highest priority, to make shure the needed packges are taken from it. This will save you from several ugly workarounds.

Also [torque-clients] is disabled, it will be used once to install torque-clients rpms from PPS native SL4 32bit build, this is the same version available in Production Repo which is build on SL3.

8) Install latest glite-yaim and lcg-CA

yum update
yum install glite-yaim
yum install lcg-CA

9) Install jakarta-commons-logging by from dag repo instead of glite repo by disabling glite repo

yum --disablerepo=glite install jakarta-commons-logging 

10) The glite classads-g3 rpm has the following requirements: libstdc++ = 3.2.3 so install compat-libstdc-3.2.3 32 bit rpm

yum install compat-libstdc++-33.i386

this will satisfy only requirement, the libstdc++ = 3.2.3 is not satisfied probably since it looks for libstdc++-33-3.2.3-47.3 and not compat-libstdc++-33-3.2.3-47.3 So download it and install manually

rpm -i --nodeps classads-g3-0.9.4-vh7_sl3.i486.rpm

11) Also install compat-openldap , since ,at least, lcg-util package binaries require But glite openldap-alt rpm puled will lcg-util are placed under /opt/openldap/lib which is not set in LD_LIBRARY_PATH ,and then added to the env results in

lcg-cr: symbol lookup error: /opt/openldap/lib/ undefined symbol: er_memcalloc

So just install compat-openldap 32 bit pkg instead

yum install compat-openldap.i386

12) Install torque rpm from PPS Native SL4 32 bit Repo by enabling it from command line, but first remove 64 bit fontconfig, since the pulled 32 bit fonconfig will conflict with it.

rpm -e --nodeps fontconfig
yum install --enablerepo=torque-clients --disablerepo=glite torque-mom

Prevent torque rpms from being updated from non torque-clients repos by locking them with yum versionlock plugin

rpm -qa | grep torque >> /etc/yum/pluginconf.d/versionlock.list

13) Install cern tkinter tix and not from glite repo

yum install --disablerepo=glite tkinter tix

14) Now you can install WN_torque rpms with

install_node site-info.def glite-WN glite-torque-client-config

or just

yum install glite-WN glite-torque-client-config

Also create empty config_yum function and put in local functions directory,since config_yum spoils the yum configuration

15) And configure

yaim -c -s site-info.def -n WN_torque

Upgrade to glite-WN_sl4compat

Since glite-WN_sl4compat now provides perl-Net-LDAP & perl-XML-SAX-Base

rpm -q --provides glite-WN_sl4compat
libstdc++ = 3.2.3
glite-WN_sl4compat = 3.0.21-0

we need to remove these rpms

rpm -e --nodeps  perl-XML-SAX-Base-1.04-1
rpm -e --nodeps perl-Net-LDAP-0.2701-1.dag.rhel3

Now if you try to update you'll get conflict between installed perl-ldap-0.31-sl3 from glite repo & going to be installed perl-LDAP-0.31-5 from slc4 repo. Looking at glite-WN_sl4compat dependencies it requires perl-LDAP

#rpm -qR glite-WN_sl4compat | egrep -e 'perl-(LDAP|ldap)'

So we can remove perl-ldap-0.31-sl3

#rpm -e --nodeps perl-ldap-0.31-sl3

Now the update should go ok.

Problematic Update Issues

1) In recent slc4 updates the openldap-2.2.13-6.4E was updated to openldap-2.2.13-7.4E, but compat-openldap-2.1.30-6.4E (which depends on openldap-2.2.13-6.4E) was not updated. So we need to prevent openldap-2.2.13-6.4E.i386 from upgrading simply by adding it to /etc/yum/pluginconf.d/versionlock.list

#echo openldap-2.2.13-6.4E.i386 >> /etc/yum/pluginconf.d/versionlock.list

1.1 The compat-openldap-2.1.30-7.4E was released today, so we can remove openldap-2.2.13-6.4E.i386 from /etc/yum/pluginconf.d/versionlock.list and run yum update

Personal tools